Author Topic: PHP 5.3  (Read 1632 times)

0 Members and 1 Guest are viewing this topic.

Offline Ramster

  • New Users
  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
PHP 5.3
« on: April 07, 2014, 06:47:12 PM »
I'm updating my server which hosts TGPx and am being told  the "version of TGPX is set up for PHP 5.2's encoding. Your new server runs PHP 5.3, as 5.2 is no longer supported and is considered a security risk"

Was there a new download that uses PHP 5.3?

Thanks!

Rob - Ramster

Offline morf

  • New Users
  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: PHP 5.3
« Reply #1 on: April 08, 2014, 03:05:32 AM »
Would like to know as well if there is a newer PHP version that works with TGPX SE.

Also where can I download files for SE version of TGPX please?

Offline scully

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: PHP 5.3
« Reply #2 on: April 19, 2014, 12:25:05 PM »
Hi Rob, for ref, I'm running the latest github download of TGPX on PHP Version 5.4.21 absolutely fine (with the mods detailed on this board). Can't say about php 5.3 though.

Offline Ramster

  • New Users
  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: PHP 5.3
« Reply #3 on: April 25, 2014, 07:32:40 AM »
Thanks Scully. We just did the server change and TPGX is not working properly. User wise it's fine but inside I cannot build pages or create thumbs when reviewing galleries. When building I get this error:
Fatal Error
Error:
Parameter 1 to txBuildCallback() expected to be a reference, value given

Trace:
call_user_func in common.php on line 480
BuildPages in common.php on line 319
BuildNewAll in index.php on line 478
call_user_func in index.php on line 57

We are on PHP 5.3 so I'm going to ask my host about 5.4 as you say you have.

Offline Ramster

  • New Users
  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: PHP 5.3
« Reply #4 on: April 25, 2014, 07:34:12 AM »
Wait, I just noticed you said "with the mods detailed on this board" . Hmmm not sure we did any mods, I'll search for these now.

Offline Robbie

  • New Users
  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: PHP 5.3
« Reply #5 on: May 13, 2014, 02:35:18 PM »
Hi scully, I can't seem to use the search here to find your posts. Could you link to the post that has your setup and mods?
-Robbie

Offline scully

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: PHP 5.3
« Reply #6 on: July 25, 2014, 12:09:01 AM »
Hi Robbie, I was meaning these mods here: http://forums.unofficialjmbsupport.com/index.php?topic=85.0

Offline bbhrucy79

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: PHP 5.3
« Reply #7 on: July 25, 2014, 08:13:40 AM »
scully,

can you pls give me your php.ini settings - the one you can reach from TGPX admin. I have also php 5.4 , and did a fresh install with all mods and its still broken ... and I suspect its some php.ini setting, maybe

Thanks

bbhrucy79

Offline bbhrucy79

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: PHP 5.3
« Reply #8 on: July 27, 2014, 07:04:33 AM »
Got it solved!

For reference if anyone runs into this problem, the problem was that the "page permissions" under general settings in the control panel was set to 666. I believe that it was set to 666 as a default setup (after installation) so you can use TGPX on shared hosting.

I set "page permissions" value to 755. And the problem solved, now I can save templates and build pages, etc.

:-)

Unofficial JMB Support Forums

Re: PHP 5.3
« Reply #8 on: July 27, 2014, 07:04:33 AM »


Tags:
 

anything